How to create empty 'DictionaryForMIDs.jar' files out of the source code?

Started by Tomcollins, 24. February 2007, 23:41:03

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Quote from: adenin__Hi Peter and everyone else!

I got the cvs directory with all the source files and a build file included from you (Peter Kmet) two weeks ago by email. Now i wanted to start to get a little bit familiar with the DictionaryForMIDs itself, not just the Generation and the Creator. But my first attempts to compile the code and put it into a jar file, so the creator takes it as a empty DFM, failed....
Maybe you could send me another build file including the build of the DFM or give me some hints how to create an empty DFM out of the source code.
I just want to try a little bit and later on, maybe if I've got some improvements i can send them to to you (or even join you as a developer)...


Quote from: adenin__Hello,

you can use this approach:

1. Install wtk 2.5 (not beta2 - it doesn't work for me with it);
add line

2. run WTK25\wtklib\Windows\bin\ktoolbar.bat
choose new project, there:

proj. name:what_you_want
midlet class name:de.kugihan.dictionaryformids.hmi_j2me.DictionaryForMIDs

then copy source tree from cvs (DictionaryForMIDs)
into WTK25\apps\what_you_want\src\

(WTK25\apps\what_you_want\src\de\... )

3. download prepared DFM (e.g.
...unpack jar file, (you can rename it to .zip ...) and from its content copy all directories except de\... into
WTK25\apps\what_you_want\classes (in this case these are 'dictionary' and 'char_lists' )

4. choose build and then Run ....and that's it !!! uoala

Quote from: Tomcollins...sad is, that I wanted to do all that work with ant scripts, but I have problem with verifying ( I must
somehow go through problem:

[exec] Error preverifying class de.kugihan.dictionaryformids.dataaccess.DictionaryDataFile
[exec] VERIFIER ERROR de/kugihan/dictionaryformids/dataaccess/DictionaryDataFile.initValues(Z)V:
[exec] Illegal type in constant pool
[exec] Result: 1

...I found just two links with solving of this problem by preverifying on google but without solution
maybe someone has Idea what it could be..


Quote from: adenin__Hi!

Thanks for your help.
Its just, that i couldn't find the wtk 2.5 (not beta release). I just can find the beta release. Sorry to bother you about this, but do you have a link where you can download the kit or something?


Quote from: Tomcollinsit works even with beta 2
...I have tried it now ...

I just take whole content of from wtk25 and pasted it to wtk25 beta2

put there this (content of old
# @( 1.13 05/12/14

kjava.preverifier.command: bin\\preverify.exe
kjava.class.path: lib\\midpapi20.jar;lib\\cldcapi10.jar
file.extension: jad com.sun.kvem.ktools.RunPro
obfuscator.runner.classpath: wtklib\\
com.sun.kvem.event_ui_1 = com.sun.kvem.midp.LocationEventGenPanel
com.sun.kvem.event_ui_2 = com.sun.kvem.midp.FileConnEventGenPanel
com.sun.kvem.event_ui_3 = com.sun.kvem.midp.TransactionPanel
com.sun.kvem.toolbar.aboutDialog.height = 266
#A flag indicating whether MIDlet-Permissions and MIDlet-Permissions-Opt
#attributes will be checked in JAR file if they are missing in JAD file
#com.sun.midp.installer.checkJarPermissions = true
# MMAPI Java 2 SE system properties
# MMAPI Java 2 SE system properties

.....that's all


Quote from: adenin__Thanks very much!!

Seems that everything works now. Great!


(Edit by Stefan1200: Made posts more readable)