Author Topic: not able to use dictionaryformids  (Read 3327 times)

0 Members and 1 Guest are viewing this topic.

hlunguite

  • Newbie
  • *
  • Posts: 7
    • View Profile
not able to use dictionaryformids
« on: 22. June 2012, 07:17:44 »
Hi

I compiled my own  DictionaryFor MIDs for android, i am not able to run.

I got " DictionaryFor MIDs (process de.kugihan.dictionaryformids.hmi_android) has stopped unexpectedly"

Anyone know the solution for this?

-hlun

axin

  • Developer
  • *****
  • Posts: 126
    • View Profile
Re: not able to use dictionaryformids
« Reply #1 on: 22. June 2012, 07:35:07 »
Hi hlun,

what's the message displayed in logcat? Often you can find some error message and detailed stack traces there.

If you are using trunk maybe there are some unknown bugs that no one discovered yet, for cross checking checking you could give the latest release branch a try.

Cheers
Axin

hlunguite

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: not able to use dictionaryformids
« Reply #2 on: 22. June 2012, 18:28:42 »
when i do  >adb logcat
nothing is printed.

but my emulator is connected to adb .

Any suggestation?

axin

  • Developer
  • *****
  • Posts: 126
    • View Profile
Re: not able to use dictionaryformids
« Reply #3 on: 23. June 2012, 10:51:33 »
Are your running the app using Eclipse? What happens if you run the app in debugging mode? Does the debugger open with an exception+stack trace?

Logcat should always give some messages, even when you don't launch any apps, as there are many processes running in background (like garbage collection, or synchronization). Maybe logcat is not connected to the correct device, or maybe Eclipse is already connected and therefore your call to adb logcat gives nothing?

hlunguite

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: not able to use dictionaryformids
« Reply #4 on: 27. June 2012, 18:36:05 »
I am able to open in emulator now after i download for the tag. But i still am not able to use the application.

Below are the steps i follow:

Create project for DictionaryForMids_3_3_0_release from svn
Download Android_0_90_1
Create New Android Project
   Build Target: Android 4.0.3
        Give Application name as AndroidDictionary package name
        Select Create Activity check box
        Minimum SDK:15
Add DictionaryForMids_3_3_0_release in java build path
Add DictionaryForMids_3_3_0_release in Project Reference
Export Signed Application package

When run in emulator i got "Hello World AndroidDictionaryActivity" display on the screen. How do i make it work?


axin

  • Developer
  • *****
  • Posts: 126
    • View Profile
Re: not able to use dictionaryformids
« Reply #5 on: 28. June 2012, 22:03:19 »
For your setup you might have to change some more settings:
- for 0.90.1 you can only target Android SDK 8
- in the Manifest, you have to specify the main activity .DictionaryForMIDs to start for the intent action.MAIN (refer to manifest from checkout for details)

An alternative way is described in belows link, basically you can use eclipse's feature to checkout existing source:
http://dictionarymid.sourceforge.net/forum/index.php?topic=273.msg1508#msg1508

Hope that helps,
axin

hlunguite

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: not able to use dictionaryformids
« Reply #6 on: 29. June 2012, 06:55:21 »
I use eclips for my work.

I will try once again.

Thanks axin for the reply

axin

  • Developer
  • *****
  • Posts: 126
    • View Profile
Re: not able to use dictionaryformids
« Reply #7 on: 03. July 2012, 19:50:24 »
Did you find a solution?

If it still doesn't work I can try to export and send you my eclipse workspace project, maybe that can get you started.

-axin

hlunguite

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: not able to use dictionaryformids
« Reply #8 on: 29. July 2012, 06:37:37 »
Hi Axin

Sorry for the late reply i was not able to login to this forum for long time.

I am still not able to make it work? it will be good if you could send me your eclipse workspace

-hlun

axin

  • Developer
  • *****
  • Posts: 126
    • View Profile
Re: not able to use dictionaryformids
« Reply #9 on: 01. August 2012, 21:16:23 »
I sent to you the export, but I'm not sure if it can really help. You still need to modify some path, e.g. to Android SDK, and maybe also add the base project to the build path of the android project.

Did it help?

Cheers,
axin

hlunguite

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: not able to use dictionaryformids
« Reply #10 on: 02. August 2012, 07:52:04 »
I just import as it is in my workspace as below

File ->import->General->Existing Project To Workspace     Select
DictionaryForMids

I got 11 error like below which i resolve by commenting those lines

 Description      Resource                       Path     Location                            Type
Invalid character constant      NormationBul.java  /DictionaryForMIDs/src/de/kugihan/dictionaryformids/translation/normation       line
18      Java Problem

Next  File -> Import->Android->Existing Android Code To WorkSpace
Select DictionaryForMids_Android

Whit i am able to generate .apk which i try with emulator and work fine.

Next i change the package name in AndroidMenifest.xml to experiment. With this I got error like below

Description   Resource    Path        Location           Type
R cannot be resolved to a variable        AboutScreen.java         de.kugihan.dictionaryformids.hmi_android.DictionaryForMIDs/src/de/kugihan/dictionaryformids/hmi_android        line
33      Java Problem